jboss-user
[Arriba] [Todas las Listas]

[jboss-Usuario] [JBoss Herramientas] - M2E dependencias perdidas en proy

To: User development <jboss-user@xxxxxxxxxxxxxxx>
Subject: [jboss-Usuario] [JBoss Herramientas] - M2E dependencias perdidas en proyecto de WTP deployment
From: daniel nitzan <do-not-reply@xxxxxxxxx>
Date: Tue, 06 Sep 2011 07:23:26 -0400
Auto-submitted: yes
Delivery-date: Tue, 06 Sep 2011 07:24:01 -0400
Envelope-to: traductor@xxxxxxxxxxx
List-archive: <http://lists.jboss.org/pipermail/jboss-user>
List-help: <mailto:jboss-user-request@lists.jboss.org?subject=help>
List-id: The JBoss User main mailing list <jboss-user.lists.jboss.org>
List-post: <mailto:jboss-user@lists.jboss.org>
List-subscribe: <https://lists.jboss.org/mailman/listinfo/jboss-user>, <mailto:jboss-user-request@lists.jboss.org?subject=subscribe>
List-unsubscribe: <https://lists.jboss.org/mailman/listinfo/jboss-user>, <mailto:jboss-user-request@lists.jboss.org?subject=unsubscribe>
Reply-to: The JBoss User main mailing list <jboss-user@xxxxxxxxxxxxxxx>
Sender: jboss-user-bounces@xxxxxxxxxxxxxxx
*daniel *nitzan [*http://Comunidad.*jboss.*org/Personas/*danydyn] creó la discusión

"*M2*E dependencias perdidas en proyecto de WTP *deployment"

para ver la discusión, visita: *http://comunidad.*jboss.*org/Mensaje/624916#624916

--------------------------------------------------------------
*Hi,

estoy utilizando  *Eclipse 3.7 + *m2*e + *m2*e-*wtp + *tomcat6.
Cuándo hago código o cambios de recurso en un proyecto de web e inicio *tomcat, *sporadically consigo *ClassNotFound excepciones.
Cuándo yo entonces inspeccionar el *tomcat despliega *dir, yo aviso que el archivo de GUERRA falta algún *jars.
El *workaround es a siempre correcto-clic en el *tomcat caso y escoge 'limpio'. Aun así, esto es bastante frustrando, desde el publica tendría que ser *incremental y automático.

He también vino alrededor de este asunto  *https://asuntos.*sonatype.*org/*browse/*MECLIPSEWTP-160 *https://asuntos.*sonatype.*org/*browse/*MECLIPSEWTP-160, podría ser relacionado.

Cualesquier pensamientos en esto?

*Thanks Anticipadamente,

Daniel
--------------------------------------------------------------

Respuesta a este mensaje por ir a Comunidad
[*http://comunidad.*jboss.*org/Mensaje/624916#624916]

Empieza una discusión nueva en *JBoss Herramientas en Comunidad
[*http://comunidad.*jboss.*org/Escoge-contenedor!Entrada.*jspa?*contentType=1&*containerType=14&contenedor=2128]

daniel nitzan [http://community.jboss.org/people/danydyn] created the discussion

"M2E missed dependencies in WTP project deployment"

To view the discussion, visit: http://community.jboss.org/message/624916#624916

--------------------------------------------------------------
Hi,

I am using  Eclipse 3.7 + m2e + m2e-wtp + tomcat6.
When I make code or resource changes on a web project and start tomcat, sporadically I get ClassNotFound exceptions.
When I then inspect the tomcat deploy dir, I notice that the WAR file is missing some jars.
The workaround is to always right-click on the tomcat instance and choose 'clean'. However, this is quite frustrating, since the publish should be incremental and automatic.

I have also came around this issue  https://issues.sonatype.org/browse/MECLIPSEWTP-160 https://issues.sonatype.org/browse/MECLIPSEWTP-160, might be related.

Any thoughts on this?

Thanks in advance,

Daniel
--------------------------------------------------------------

Reply to this message by going to Community
[http://community.jboss.org/message/624916#624916]

Start a new discussion in JBoss Tools at Community
[http://community.jboss.org/choose-container!input.jspa?contentType=1&containerType=14&container=2128]

_______________________________________________
*jboss-Usuario *mailing lista
*jboss-user@xxxxxxxxxxxxxxx
*https://listas.*jboss.*org/*mailman/*listinfo/*jboss-Usuario
_______________________________________________
jboss-user mailing list
jboss-user@xxxxxxxxxxxxxxx
https://lists.jboss.org/mailman/listinfo/jboss-user
<Anterior por Tema] Tema Actual [Siguiente por Tema>