jboss-user
[Arriba] [Todas las Listas]

[jboss-Usuario] [JBoss Herramientas] - Jboss Maven Jsf Integración: Car

To: User development <jboss-user@xxxxxxxxxxxxxxx>
Subject: [jboss-Usuario] [JBoss Herramientas] - Jboss Maven Jsf Integración: Caras-config.xml Problema de editor
From: "yoel.ben" <do-not-reply@xxxxxxxxx>
Date: Mon, 19 Sep 2011 12:35:12 -0400
Auto-submitted: yes
Delivery-date: Mon, 19 Sep 2011 12:36:22 -0400
Envelope-to: traductor@xxxxxxxxxxx
List-archive: <http://lists.jboss.org/pipermail/jboss-user>
List-help: <mailto:jboss-user-request@lists.jboss.org?subject=help>
List-id: The JBoss User main mailing list <jboss-user.lists.jboss.org>
List-post: <mailto:jboss-user@lists.jboss.org>
List-subscribe: <https://lists.jboss.org/mailman/listinfo/jboss-user>, <mailto:jboss-user-request@lists.jboss.org?subject=subscribe>
List-unsubscribe: <https://lists.jboss.org/mailman/listinfo/jboss-user>, <mailto:jboss-user-request@lists.jboss.org?subject=unsubscribe>
Reply-to: The JBoss User main mailing list <jboss-user@xxxxxxxxxxxxxxx>
Sender: jboss-user-bounces@xxxxxxxxxxxxxxx
*yoel.*ben [*http://Comunidad.*jboss.*org/Personas/*yoel.*ben] Creó la discusión

"*Jboss *Maven *Jsf Integración: Caras-*config.*xml Problema de editor"

para ver la discusión, visita: *http://comunidad.*jboss.*org/Mensaje/627276#627276

--------------------------------------------------------------
*Dear todo,

Mi problema es que quiero utilizar *Eclipse *JSF Caras-*config editor para dibujar reglas de navegación entre *xhtml página.
Pero con el uso de *Jboss *Maven *Jsf Integración es parece imposible (ve el archivo en *attachment).

He detectado el problema :
El *Jboss *plugin añade en el archivo  **org.*eclipse.*wst.Común.Componente :*
*       ...*
*       <*wb-El Recurso despliega-fuente="/" de camino-objetivo="/de camino/*m2*e-*wtp/web-recursos"/>*
       <*wb-el recurso despliega-fuente="/" de camino-camino="/*src/principal/*webapp"/>  *...*

Y el *Eclipse caras-*config el editor parece para cargar el primer *wb-recurso con la fuente "de atributo-camino" e ignorando el próximo un.
Si tú *inverse #este dos *ligns. Los trabajos de editores de las caras (podemos escogió Página para definir reglas de Navegación).
Pero cuándo un *maven actualiza configuración de proyecto es lanzamiento, el *plugin escribe *<*wb-el recurso despliega-fuente="/" de camino-objetivo="/de camino/*m2*e-*wtp/web-recursos"/>* siempre antes de *wb-el  <recurso despliega-fuente="/" de camino-camino="/*src/principal/*webapp"/>.

Lo es un *bug de *Jboss Herramientas o del Editor?
--------------------------------------------------------------

Respuesta a este mensaje por ir a Comunidad
[*http://comunidad.*jboss.*org/Mensaje/627276#627276]

Empieza una discusión nueva en *JBoss Herramientas en Comunidad
[*http://comunidad.*jboss.*org/Escoge-contenedor!Entrada.*jspa?*contentType=1&*containerType=14&contenedor=2128]

yoel.ben [http://community.jboss.org/people/yoel.ben] created the discussion

"Jboss Maven Jsf Integration: Faces-config.xml Editor Problem"

To view the discussion, visit: http://community.jboss.org/message/627276#627276

--------------------------------------------------------------
Dear all,

My problem is that I want to use Eclipse JSF Faces-config editor to draw navigation rules between xhtml page.
But with the use of Jboss Maven Jsf Integration it's seem impossible (see the file in attachment).

I have detected the problem :
The Jboss plugin adds in the file  *org.eclipse.wst.common.component :*
*       ...*
*       <wb-resource deploy-path="/" source-path="/target/m2e-wtp/web-resources"/>*
       <wb-resource deploy-path="/" source-path="/src/main/webapp"/>  *...*

And the Eclipse faces-config editor seems to load the first wb-resource with the attribute "source-path" and ignoring the next one.
If you inverse these two ligns. the faces editors works (we can chose Page to define Navigation rules).
But when an maven update project configuration is launch, the plugin writes *<wb-resource deploy-path="/" source-path="/target/m2e-wtp/web-resources"/>* always before  <wb-resource deploy-path="/" source-path="/src/main/webapp"/>.

Is it a bug of Jboss Tools or of the Editor?
--------------------------------------------------------------

Reply to this message by going to Community
[http://community.jboss.org/message/627276#627276]

Start a new discussion in JBoss Tools at Community
[http://community.jboss.org/choose-container!input.jspa?contentType=1&containerType=14&container=2128]

_______________________________________________
*jboss-Usuario *mailing lista
*jboss-user@xxxxxxxxxxxxxxx
*https://listas.*jboss.*org/*mailman/*listinfo/*jboss-Usuario
_______________________________________________
jboss-user mailing list
jboss-user@xxxxxxxxxxxxxxx
https://lists.jboss.org/mailman/listinfo/jboss-user
<Anterior por Tema] Tema Actual [Siguiente por Tema>