mongodb-user
[Arriba] [Todas las Listas]

[mongodb-Usuario] Re: Cant authenticate petición con SCRAM-SHA-1 mecani

To: mongodb-user <mongodb-user@xxxxxxxxxxxxxxxx>
Subject: [mongodb-Usuario] Re: Cant authenticate petición con SCRAM-SHA-1 mecanismo
From: Guillermo <guillermoly@xxxxxxxxx>
Date: Mon, 1 Feb 2016 06:21:06 -0800 (PST)
Delivery-date: Mon, 01 Feb 2016 09:21:16 -0500
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=googlegroups.com; s=20120806; h=date:from:to:message-id:in-reply-to:references:subject:mime-version :content-type:x-original-sender:reply-to:precedence:mailing-list :list-id:x-spam-checked-in-group:list-post:list-help:list-archive :sender:list-subscribe:list-unsubscribe; bh=NbQxCmDo7nDKjgNE8YS9GfUX/X2tmWRTOeNzhYOxK14=; b=TC8kaOXlEBSqPTtMlA7WowaykNdWeLP52EcHFNQVRJEu9BGbaEJkJLKbnUQvw5vpxc vu3uDO8tvsCJp4hC0vF/aPBdmkAK2xZWPiIQFHeKZ1HLdSlLnu5zJKPve+iWN2ehh9NU j5S0KheBRTE05BRCHrc2bHPlwG89nmIu7qR8H76OV7N6QbdQ71pqt2zzKH1X2YLSKqLw stDM/g81JN5J3FnAb025A9xRwAa6BQnWK+5vh6e5GurGdegC2jS4cZrKSh4MSbZPkYA9 WobZucIzuZNKoQ4+j1Cg20/L0QHmLFZsJbI1HBnRQhNsdEm/ACBxVkRN/heAZIvjupm6 y1Tw==
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=date:from:to:message-id:in-reply-to:references:subject:mime-version :content-type:x-original-sender:reply-to:precedence:mailing-list :list-id:x-spam-checked-in-group:list-post:list-help:list-archive :sender:list-subscribe:list-unsubscribe; bh=NbQxCmDo7nDKjgNE8YS9GfUX/X2tmWRTOeNzhYOxK14=; b=t9tEnQcvik122rKVdlSgd2qQP0NFQ364GHphk0y/dPYwwadwmG+UZJxA/WXuF/lrHg mTUFCUZf2YAJTXe4A2eFaxUD+ub8QjcDy+fIAwJU77qHj+i4TO5VNeXX5DbPjm7EmKA+ k4Ox1JLigAOHUXfWGlaNKoNQ9Q632bZt1m4h5O36LY0gi++xOX1pruR1vgbt3CvykQrw L6NX8yrxwgwcqYoJCcko+AVEk3F5gTGaNBcXKIS9RL+rUpxtGMs1y+F5yDK0260phg4H YiXh4iTe56cX+Wfz88IJSe+kIMPl2nnwbHzbIu1SugEnWItnZcvMz0wvskSGMYIPyZpI xp+w==
Envelope-to: traductor@xxxxxxxxxxx
In-reply-to: <d818201e-601e-4850-b4d2-0dfc64d293d6@googlegroups.com>
List-archive: <https://groups.google.com/group/mongodb-use>
List-help: <https://groups.google.com/support/>, <mailto:mongodb-user+help@googlegroups.com>
List-id: <mongodb-user.googlegroups.com>
List-post: <https://groups.google.com/group/mongodb-user/post>, <mailto:mongodb-user@googlegroups.com>
List-subscribe: <https://groups.google.com/group/mongodb-user/subscribe>, <mailto:mongodb-user+subscribe@googlegroups.com>
List-unsubscribe: <mailto:googlegroups-manage+1044811755470+unsubscribe@googlegroups.com>, <https://groups.google.com/group/mongodb-user/subscribe>
Mailing-list: list mongodb-user@xxxxxxxxxxxxxxxx; contact mongodb-user+owners@xxxxxxxxxxxxxxxx
References: <d818201e-601e-4850-b4d2-0dfc64d293d6@googlegroups.com>
Reply-to: mongodb-user@xxxxxxxxxxxxxxxx
Sender: mongodb-user@xxxxxxxxxxxxxxxx
*Ok *sorry, yo *wasnt *initializing el conductor correctamente. Su laborable ahora.

*El *lunes, 25 *de *enero *de 2016, 13:32:13 (*UTC+1), Guillermo *escribió:
>
> estoy intentando hacer una petición sencilla a un *mongo *database, pero él *terminates 
> después del siguiendo error
>
> *terminate llamado después de echar un caso de '*mongo::*UserException'
>
> qué():  SCRAM-*SHA-1 mecanismo apoya no *compiled a biblioteca de cliente. 
>> (Algunos mecanismos requieren el conductor ser *compiled con las banderas --*ssl o --uso-*sasl-cliente) 
>> 
>
>
>  yo *dont entender por qué su *complaining sobre aquello. He instalado la biblioteca 
> *libsasl2-*dev, y mi *scons la orden es el siguiendo: 
>
> *sudo *scons -*j 4 --imposibilitar-avisos-tan-errores --*c++11=en --*ssl 
>> --*sharedclient --el prefijo=/opta/*mongo-el cliente instala
>
>
> Y el código *Im utilizando para hacer la petición es el siguiendo:
>
>
>>     *mongo::*DBClientConnection *conn;
>>     *std::cadena *url = anfitrión + ":" + puerto;
>>     //Conecta a *database
>>     *conn.Conecta(*url);
>>     *conn.*auth(*dbname,usuario,contraseña,*errmsg, cierto);
>
>
> también he probado esto, en vez de la última línea:
>
>     *conn.*auth( *BSON(
>>     "Usuario" << de usuario <<
>>     "*pwd" << SCRAM <<
>>     "de mecanismo" << "de la contraseña-*SHA-1" <<
>>     "*db" << *dbname ) );
>
>
>  Cualesquier ideas? Por qué lo es *complaining sobre no habiendo *compiled con --*ssl o --uso-*sasl-cliente? 
> Utilicé aquellas opciones!
>

-- 
Recibiste este mensaje porque eres *subscribed al *Google Grupos "*mongodb-grupo"
de usuario.

Para otro *MongoDB opciones de apoyo técnico, ve: *http://www.mongodb.org/sobre/apoyo/.
--- 
Recibiste este mensaje porque eres *subscribed al *Google Grupos "*mongodb-grupo" de usuario.
A *unsubscribe de este grupo y la parón que recibe *emails de él, enviar un *email a *mongodb-usuario+unsubscribe@xxxxxxxxxxxxxxxx.
A correo a este grupo, envía *email a *mongodb-user@xxxxxxxxxxxxxxxx.
Visita este grupo en *https://grupos.*google.*com/Grupo/*mongodb-usuario.
Para ver esta discusión en la visita de web *https://grupos.*google.*com/*d/*msgid/*mongodb-Usuario/790*c929*e-307un-4985-8233-3*abc73882*cdc%40*googlegroups.*com.
Para más opciones, visita *https://grupos.*google.*com/*d/*optout.
Ok sorry, I wasnt initializing the driver properly. Its working now.

El lunes, 25 de enero de 2016, 13:32:13 (UTC+1), Guillermo escribió:
>
> I am trying to do a simple request to a mongo database, but it terminates 
> after the following error
>
> terminate called after throwing an instance of 'mongo::UserException'
>
> what():  SCRAM-SHA-1 mechanism support not compiled into client library. 
>> (Some mechanisms require the driver be compiled with the flags --ssl or 
>> --use-sasl-client)
>
>
>  I dont understand why its complaining about that. I have installed the 
> library libsasl2-dev, and my scons command is the following: 
>
> sudo scons -j 4 --disable-warnings-as-errors --c++11=on --ssl 
>> --sharedclient --prefix=/opt/mongo-client install
>
>
> And the code Im using to do the request is the following:
>
>
>>     mongo::DBClientConnection conn;
>>     std::string url = host + ":" + port;
>>     //Connect to database
>>     conn.connect(url);
>>     conn.auth(dbname,user,password,errmsg, true);
>
>
> I have also tried this, instead of the last line:
>
>     conn.auth( BSON(
>>     "user" << user <<
>>     "pwd" << password <<
>>     "mechanism" << "SCRAM-SHA-1" <<
>>     "db" << dbname ) );
>
>
>  Any ideas? Why is it complaining about not having compiled with --ssl or 
> --use-sasl-client? I did use those options!
>

-- 
You received this message because you are subscribed to the Google Groups "mongodb-user"
group.

For other MongoDB technical support options, see: http://www.mongodb.org/about/support/.
--- 
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+unsubscribe@xxxxxxxxxxxxxxxx.
To post to this group, send email to mongodb-user@xxxxxxxxxxxxxxxx.
Visit this group at https://groups.google.com/group/mongodb-user.
To view this discussion on the web visit https://groups.google.com/d/msgid/mongodb-user/790c929e-307a-4985-8233-3abc73882cdc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
<Anterior por Tema] Tema Actual [Siguiente por Tema>
  • [mongodb-Usuario] Re: Cant authenticate petición con SCRAM-SHA-1 mecanismo, Guillermo <=