opencv
[Arriba] [Todas las Listas]

[OpenCV] Problema con número de grupos en entrenar algoritmo de EM con

To: OpenCV@xxxxxxxxxxxxxxx
Subject: [OpenCV] Problema con número de grupos en entrenar algoritmo de EM con CvEM
From: "Daniel" <daniel.svoboda@xxxxxxxxx>
Date: Fri, 02 Mar 2012 16:01:12 -0000
Delivered-to: mailing list OpenCV@xxxxxxxxxxxxxxx
Delivery-date: Mon, 05 Mar 2012 07:29:05 -0500
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoogroups.com; s=lima; t=1330950539; bh=Wndnpvqm2rGzNHqEUGZ4pm9wUcJMZLjklBlwm/m6ao4=; h=Received:Received:Received:X-Yahoo-Newman-Id:Received:Received:Received:DKIM-Signature:Received:Received:Received:X-Sender:X-Apparently-To:X-Received:X-Received:X-Received:X-Received:X-Received:X-Received:To:Message-ID:User-Agent:X-Mailer:X-Originating-IP:X-Yahoo-Post-IP:From:X-Yahoo-Profile:X-eGroups-Approved-By:Sender:MIME-Version:Mailing-List:Delivered-To:List-Id:Precedence:List-Unsubscribe:Date:Subject:Reply-To:X-Yahoo-Newman-Property:Content-Type; b=LQaAEAgqT5szwddOPqIoxWOJZc2AzyF7Qtds9pFekYV8pF3SmK8JbqxEk5DiixS6voCBFRu52ni6lMhO+m3KW7fggmt0Jf2Oxt2CvsLwMrncAMEWQEqj3TPDJtbuSEyG
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoogroups.com; s=lima; t=1330950533; bh=jdPklcZMnjlYsHkR5hyD9moe4/ZPv/s/5YAfc0RHQNQ=; h=Received:Received:Received:X-Sender:X-Apparently-To:X-Received:X-Received:X-Received:X-Received:X-Received:X-Received:Date:To:Message-ID:User-Agent:MIME-Version:Content-Type:Content-Transfer-Encoding:X-Mailer:X-Yahoo-Newman-Property:X-Originating-IP:X-Yahoo-Post-IP:From:Subject:X-Yahoo-Group-Post:X-Yahoo-Profile:X-YGroups-SubInfo:Sender:X-eGroups-Approved-By:X-eGroups-Auth; b=pChRJJ/iOo8JR+Cl0ghstkMVuoWhTbxvkhSNiNuHJO8lMU4/j4RujdW88qZ+tfCnT0cIsXFrk/kTru4W6lOBZetGwJ2kmSeHbnH3xj+NSnlOo0mVXS3JTC9wfQr8QoZ8
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=lima; d=yahoogroups.com; b=ZyLCjQBg7IS3+1ShzRfKnurLw8i/s9K8s2QKncbYhP/6U7dPvtvUv7EU/trL7G7qKWLcDI2cClgLZGcyaNzAXR1XmCbEtIDHBK4j0cO+JT86xppWhueObsk7ihc7IdjV;
Envelope-to: traductor@xxxxxxxxxxx
List-id: <OpenCV.yahoogroups.com>
List-unsubscribe: <mailto:OpenCV-unsubscribe@yahoogroups.com>
Mailing-list: list OpenCV@xxxxxxxxxxxxxxx; contact OpenCV-owner@xxxxxxxxxxxxxxx
Reply-to: OpenCV@xxxxxxxxxxxxxxx
Sender: OpenCV@xxxxxxxxxxxxxxx
User-agent: eGroups-EW/0.82
Estoy intentando para utilizar el *CvEM clase para entrenar un *Gaussian *Mixture Modelo.  Puedo crear el modelo bien.  Necesito salvar el modelo a un archivo de texto que contiene sus parámetros (pesos, significa, *covariance matrices, *etc.).  Utilizo el salvar método para esto.  Cuándo cargo arriba del modelo a un programa diferente y correrlo, consigo un *segmentation error si el número de grupos utilicé para entrenar el modelo era más grande que 10.  No tengo este problema si el número de los grupos utilizados para entrenar esto era 10 o menos.  No tengo un problema que trabaja con el modelo con 11 o más grupos si había sido entrenado en el mismo programa.  Sólo ocurre cuándo cargo el modelo a un programa diferente.  Haciendo un *gdb *backtrace revela que el error ocurre cuándo los intentos de programa para llamar el *CvEM *destructor.  Parece que algo no es cargado cuándo utilizo la característica de carga.  Cualquiera no estoy salvando y/o cargándolo correctamente, o tiene que haber un *bug con *OpenCV.

I'm attempting to use the CvEM class for training a Gaussian Mixture Model.  I can create the model fine.  I need to save the model to a text file that contains its parameters (weights, means, covariance matrices, etc.).  I use the save method for this.  When I load up the model into a different program and run it, I get a segmentation error if the number of clusters I used to train the model was greater than 10.  I do not have this problem if the number of clusters used to train this was 10 or less.  I do not have a problem working with the model with 11 or more clusters if it had been trained in the same program.  It only occurs when I load the model into a different program.  Doing a gdb backtrace reveals that the error occurs when the program attempts to call the CvEM destructor.  It seems that something is not loaded when I use the load feature.  Either I'm not saving and/or loading it correctly, or there must be a bug with OpenCV.

<Anterior por Tema] Tema Actual [Siguiente por Tema>
  • [OpenCV] Problema con número de grupos en entrenar algoritmo de EM con CvEM, Daniel <=