opensuse
[Arriba] [Todas las Listas]

Re: [opensuse] Actualiza de repositories/X11:/XOrg/openSUSE_11.4/ ROMPIÃ

To: opensuse@xxxxxxxxxxxx
Subject: Re: [opensuse] Actualiza de repositories/X11:/XOrg/openSUSE_11.4/ ROMPIÓ xorg hoy
From: Anton Aylward <opensuse@xxxxxxxxxxxxxxxx>
Date: Fri, 09 Sep 2011 09:24:13 -0400
Delivered-to: opensuse@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 09 Sep 2011 09:24:36 -0400
Dkim-signature: v=1; a=rsa-sha1; c=relaxed; d=antonaylward.com; h= message-id:date:from:mime-version:to:subject:references :in-reply-to:content-type:content-transfer-encoding; s= antonaylward.com; bh=J5fxdHl3C83Ua+WfNBKZgNIN1aQ=; b=BYbfvJGcjcY WsM4rvUfxPz33Ufo3zjEUBpXTFt7+yexixTQlSyW+o8m4ES4zHQo2dPU1NhQdbKz qYRdTveTOVr/iokG7gt7rrMPlrkslZXhHEvaQRLFX89WZ+M7vnNQ01+PSxsCxamI AWjnR6eYaQCZFAPes9MBijxqmtReTIh0=
Domainkey-signature: a=rsa-sha1; c=nofws; d=antonaylward.com; h=message-id :date:from:mime-version:to:subject:references:in-reply-to :content-type:content-transfer-encoding; q=dns; s= antonaylward.com; b=erbdBzo3yl2yRCBGP8RhJWy0B3Kkdg7ZuRENjYpU7yKD V58QIy5qQCi2lZV9r1kobQue8t3vz3g9hjle2n8UfOn0xMHDLFaiXj62ToJWd5Ha WG9nNpz0/pbrbkwTepkH8Ct9VNKJ7MHYCQXPeilwO4kOg00CcpL3BpGcB6wmUSI=
Envelope-to: traductor@xxxxxxxxxxx
In-reply-to: <4E698CA7.9050701@suddenlinkmail.com>
List-archive: <http://lists.opensuse.org/opensuse/>
List-help: <mailto:opensuse+help@opensuse.org>
List-owner: <mailto:opensuse+owner@opensuse.org>
List-post: <mailto:opensuse@opensuse.org>
List-subscribe: <mailto:opensuse+subscribe@opensuse.org>
List-unsubscribe: <mailto:opensuse+unsubscribe@opensuse.org>
Mailing-list: contact opensuse+help@xxxxxxxxxxxx; run by mlmmj
Organization: SI
References: <4E698CA7.9050701@suddenlinkmail.com>
User-agent: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20110812 Firefox/6.0 Thunderbird/6.0
David *C. *Rankin Dijo el siguiendo en 09/08/2011 11:48 PM:
*guys

    Actualiza esta noche del *xorg *repo rompió *x en mi *toshiba *laptop. El sistema
chutaría y ser vertido a consola con algún mensaje sobre no siendo capaz de mover
*Xorg.0.*log A *Xorg.0.*log.Viejo (*ho *hum...)

Que _puede ser un problema de permisos.
Depende en cómo empiezas *X

Si estás utilizando *runlevel 5 entonces *kdm tendría que ser correr como raíz y *kdm empezará *X y allí tener que'*nt ser un problema.

Si eres habiendo problemas con *kdm (o *xdm o *gdm) [como mí] y está empezando de la línea de orden como usuario con '*startx' entonces *X es empezado con vuestro usuario (*i.*e. No arraigar) ID y así que no puede mover el *log archivo desde /*var/*log es poseído por raíz y no *writable por usuarios meros.

Así que necesitas un /*etc/permisos.Local

   # *setuid mordió en *Xorg es sólo necesitado si ningún director de exhibición, *ie *startx
   # es utilizado. *Beware De *CVE-2010-2240.
   #
   /*usr/Cubo/*Xorg                 raíz:raíz       4711

y entonces corrido como raíz:

	*chkstat -puesto /*etc/permisos.Local


    El *rpms actualizado era:

/*var/*cache/*zypp/paquetes/*xorg/*noarch:
*xkeyboard-*config-2.2.1-25.18.*noarch.*rpm
*xorg-*x11-*libX11-*ccache-7.6-16.56.*noarch.*rpm

/*var/*cache/*zypp/Paquetes/*xorg/*x86_64:
*xorg-*x11-*server-7.6_1.10.4-163.1.*x86_64.*rpm
*xorg-*x11-*server-extra-7.6_1.10.4-163.1.*x86_64.*rpm
*xorg-*x11-*Xvnc-7.6_1.10.4-163.1.*x86_64.*rpm

    *Downgrading Aquellos archiva sólo dejaría *X para empezar, pero había ningún
teclado o entrada de ratón aceptada por el director de exhibición.

Todavía consigo que a veces pero me pregunto si mi hardware está actuando arriba de más

> Lejano *downgrading del
siguiendo conseguido la caja que corre otra vez:

*rpm -*Uvh --*oldpackage *xkeyboard-*config-2.2.1-25.9.*noarch.*rpm \
*xorg-*x11-*libX11-*ccache-7.6-16.44.*noarch.*rpm \
*xorg-*x11-*Xvnc-7.6_1.9.3-157.5.*x86_64.*rpm \
*xorg-*x11-*xauth-7.6-175.7.*x86_64.*rpm \
*xorg-*x11-*server-extra-7.6_1.9.3-157.5.*x86_64.*rpm \
*xorg-*x11-*server-7.6_1.9.3-157.5.*x86_64.*rpm \
*xorg-*x11-conductor-vídeo-*nouveau-0.0.16_20110115_*b795*ca6-25.3.*x86_64.*rpm \
*xorg-*x11-conductor-entrada-7.6-117.2.*x86_64.*rpm

    Es cualquiera más experimentando problemas con estos nuevo *xorg paquetes? Si tan dejado
me sabe. *Thanks.

He sido habiendo muchos problemas con *xorg paquetes o sobre un mes ahora.



--
Al menos cuándo los humanos van a *casualty, generalmente no han ido al Tablero de Control y *messed con el *settings...
--
A *unsubscribe, *e-correo: *opensuse+unsubscribe@xxxxxxxxxxxx
Puesto que órdenes adicionales, *e-correo: *opensuse+help@xxxxxxxxxxxx


David C. Rankin said the following on 09/08/2011 11:48 PM:
guys

    Updates tonight from the xorg repo broke x on my toshiba laptop. The system
would boot and be dumped to console with some message about not being able to
move Xorg.0.log to Xorg.0.log.old (ho hum...)

That _may_ be a permissions problem.
It depends on how you start X

If you are using runlevel 5 then kdm should be running as root and kdm will start X and there should'nt be a problem.

If you are having problems with kdm (or xdm or gdm) [like me] and are starting from the command line as a user with 'startx' then X is started with your user (i.e. not root) ID and so can't move the log file since /var/log is owned by root and not writable by mere users.

So you need a /etc/permissions.local

   # setuid bit on Xorg is only needed if no display manager, ie startx
   # is used. Beware of CVE-2010-2240.
   #
   /usr/bin/Xorg                 root:root       4711

and then run as root:

	chkstat -set /etc/permissions.local


    The rpms updated were:

/var/cache/zypp/packages/xorg/noarch:
xkeyboard-config-2.2.1-25.18.noarch.rpm
xorg-x11-libX11-ccache-7.6-16.56.noarch.rpm

/var/cache/zypp/packages/xorg/x86_64:
xorg-x11-server-7.6_1.10.4-163.1.x86_64.rpm
xorg-x11-server-extra-7.6_1.10.4-163.1.x86_64.rpm
xorg-x11-Xvnc-7.6_1.10.4-163.1.x86_64.rpm

    Downgrading those files alone would allow X to start, but there was no
keyboard or mouse input accepted by the display manager.

I still get that sometimes but I wonder if my hardware is acting up

> Further downgrading of
the following got the box running again:

rpm -Uvh --oldpackage xkeyboard-config-2.2.1-25.9.noarch.rpm \
xorg-x11-libX11-ccache-7.6-16.44.noarch.rpm \
xorg-x11-Xvnc-7.6_1.9.3-157.5.x86_64.rpm \
xorg-x11-xauth-7.6-175.7.x86_64.rpm \
xorg-x11-server-extra-7.6_1.9.3-157.5.x86_64.rpm \
xorg-x11-server-7.6_1.9.3-157.5.x86_64.rpm \
xorg-x11-driver-video-nouveau-0.0.16_20110115_b795ca6-25.3.x86_64.rpm \
xorg-x11-driver-input-7.6-117.2.x86_64.rpm

    Is anybody else experiencing problems with these new xorg packages? If so let
me know. Thanks.

I've been having a LOT of problems with xorg packages or over a month now.



--
At least when humans go to casualty, they generally haven't gone into the Control Panel and messed with the settings...
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx


<Anterior por Tema] Tema Actual [Siguiente por Tema>