zope
[Arriba] [Todas las Listas]

Re: [Zope] Utilizando WebServerAuth

To: zope@xxxxxxxx
Subject: Re: [Zope] Utilizando WebServerAuth
From: Alex Clark <aclark@xxxxxxxxxx>
Date: Mon, 29 Oct 2012 19:18:10 -0400
Delivered-to: zope@xxxxxxxx
Delivery-date: Mon, 29 Oct 2012 19:18:31 -0400
Envelope-to: traductor@xxxxxxxxxxx
List-archive: <http://mail.zope.org/pipermail/zope/>
List-help: <mailto:zope-request@zope.org?subject=help>
List-id: Users of the Z Object Publishing Environment <zope.zope.org>
List-post: <mailto:zope@zope.org>
List-subscribe: <https://mail.zope.org/mailman/listinfo/zope>, <mailto:zope-request@zope.org?subject=subscribe>
List-unsubscribe: <https://mail.zope.org/mailman/options/zope>, <mailto:zope-request@zope.org?subject=unsubscribe>
Organization: ACLARK.NET, LLC
References: <508EBCB4.6010100@ed.ac.uk>
Sender: zope-bounces@xxxxxxxx
User-agent: Unison/2.1.9
En 2012-10-29 17:28:20 +0000, Shane *Voss dicho:

estoy intentando traer actual un existiendo *Zope monta correr en una versión
obsoleta de *Zope.  Estoy intentando conseguir *WebServerAuth para trabajar para mí cuando parece
para ser el obvio *replacement para la casa-sistema crecido en sitio en
el saliendo *server.

Tan lejos, he sido incapaz de hacerlo aparece en la lista de Productos.

Cambié mi  *buildout.*cfg  Y el Producto ahora aparece en  la carpeta  de huevos
de mi *Zope instalación, pero no en el *ZMI Tablero de Control

fundo (y conjunto) en *zope.*conf:  Habilita-producto-instalación en
Tan sé que un número de otros productos es trae instalado.

Probé añadir un *suitable vínculo en el directorio de Productos del Caso.
Aquello resultado en  "el módulo no funda"  los errores que me dirigen para instalar Productos
adicionales (*PluggableAuthService y *CMFCore) y para enlazar aquellos dentro al
directorio de Productos también.

Ahora he logrado *impasse con *CMFCore  *complaining:

    de *zope.*globalrequest Importación *getRequest
       *ImportError: Ningún módulo nombrado *globalrequest

he encontrado e instalado (con *buildout) el  *zope.*globalrequest  Huevo, pero no puedo salir cómo a *bodge cualesquier vínculos para hacer trabajo de cosas.

Tan...

Puede cualquiera me dice cómo para instalar este Producto ?
(Todo esto está siendo hecho con *Zope2-2.13.18  )


no cualquier cosa a mano; uso *buildout. Y desde *WebServerAuth era originalmente pretendido para uso con *Plone, no aparece para `instalar_requiere` *CMFCore y/o *PluggableAuthService (cuál probablemente tiene que).

Estos trabajos para mí al menos bastante para empezar *Zope2:

---

[*buildout]
extiende = *https://crudo.*github.*com/*pythonpackages/*buildout-*zope2/maestro/2.13.*x

[*zope2]
Productos +=
   de huevos.*CMFCore
   Productos.*PluggableAuthService
   Productos.*WebServerAuth

---


*Lastly, probablemente necesitarás reemplazar vuestro *acl_usuarios con un PAS *e.*g.:

- *https://*github.*com/*aclark4vida/*Zope2-*Plus-PAS








    Shane


--
Alex Clark *· *https://www.gittip.com/*aclark4vida/


_______________________________________________
*Zope *maillist  -  Zope@xxxxxxxx
*https://correo.*zope.*org/*mailman/*listinfo/*zope
**   #Ninguno correos de cruz o HTML *encoding!  **
(Listas relacionadas -
*https://correo.*zope.*org/*mailman/*listinfo/*zope-Anunciar
*https://correo.*zope.*org/*mailman/*listinfo/*zope-*dev )

On 2012-10-29 17:28:20 +0000, Shane Voss said:

I am trying to bring up-to-date an existing Zope set up running on an obsolete
version of Zope.  I am trying to get WebServerAuth to work for me as it seems
to be the obvious replacement for the home-grown system in place on the
exiting server.

So far, I have been unable to make it appear in the Products list.

I changed my  buildout.cfg  and the Product now appears in the  eggs  folder
of my Zope installation, but not in the ZMI Control Panel

I found (and set) in zope.conf:  enable-product-installation on
So I know that a number of other products are bring installed.

I tried adding a suitable link in the Instance Products directory.
That resulted in  "module not found"  errors leading me to install additional
Products (PluggableAuthService and CMFCore) and to link those in to the
Products directory too.

I have now reached impasse with  CMFCore complaining:

    from zope.globalrequest import getRequest
       ImportError: No module named globalrequest

I have found and installed (with buildout) the  zope.globalrequest  egg, but I
can't work out how to bodge any links to make things work.

So...

Can anyone tell me how to install this Product ?
(All this is being done with  Zope2-2.13.18 )


Don't do anything by hand; use buildout. And since WebServerAuth was originally intended for use with Plone, it does not appear to `install_requires` CMFCore and/or PluggableAuthService (which it probably should).

This works for me at least enough to start Zope2:

---

[buildout]
extends = https://raw.github.com/pythonpackages/buildout-zope2/master/2.13.x

[zope2]
eggs +=
   Products.CMFCore
   Products.PluggableAuthService
   Products.WebServerAuth

---


Lastly, you'll likely need to replace your acl_users with a PAS e.g.:

- https://github.com/aclark4life/Zope2-Plus-PAS








    Shane


--
Alex Clark · https://www.gittip.com/aclark4life/


_______________________________________________
Zope maillist  -  Zope@xxxxxxxx
https://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
https://mail.zope.org/mailman/listinfo/zope-announce
https://mail.zope.org/mailman/listinfo/zope-dev )

<Anterior por Tema] Tema Actual [Siguiente por Tema>